Description

The Barareh village is on fire due to the attack of the virtual enemy. Several places are already on fire and the fire is spreading fast to other places. Khorzookhan who is the only person remaining alive in the war with the virtual enemy, tries to rescue himself by reaching to the only helicopter in the Barareh villiage. Suppose the Barareh village is represented by an n × m grid. At the initial time, some grid cells are on fire. If a cell catches fire at time x, all its 8 vertex-neighboring cells will catch fire at time x + k. If a cell catches fire, it will be on fire forever. At the initial time, Khorzookhan stands at cell s and the helicopter is located at cell t. At any time x, Khorzookhan can move from its current cell to one of four edge-neighboring cells, located at the left, right, top, or bottom of its current cell if that cell is not on fire at time x + 1. Note that each move takes one second. Your task is to write a program to find the shortest path from s to t avoiding fire.

Input

There are multiple test cases in the input. The first line of each test case contains three positive integers n, m and k (1 ⩽ n,m,k ⩽ 100), where n and m indicate the size of the test case grid n × m, and k denotes the growth rate of fire. The next n lines, each contains a string of length m, where the jth character of the ith line represents the cell (i, j) of the grid. Cells which are on fire at time 0, are presented by character “f”. There may exist no “f” in the test case. The helicopter and Khorzookhan are located at cells presented by “t” and “s”, respectively. Other cells are filled by “-” characters. The input terminates with a line containing “0 0 0” which should not be processed.

Output

For each test case, output a line containing the shortest time to reach t from s avoiding fire. If it is impossible to reach t from s, write “Impossible” in the output.

Sample Input

7 7 2
f------
-f---f-
----f--
-------
------f
---s---
t----f-
3 4 1
t--f
--s-
----
2 2 1
st
f-
2 2 2
st
f-
0 0 0

Sample Output

4
Impossible
Impossible
1

Hint


两遍bfs,第一遍预处理每个点火烧到的时间,第二遍判断人是否能安全逃生
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
struct point{
	int x, y,time;
};
int vis[110][110],vis1[110][110], time_[110][110], dir[8][2] = {1,0, 0,1, -1,0, 0,-1, 1,1, 1,-1, -1,1, -1,-1};
char map[110][110];
int m, n, k,time1;
queue<point>q;

bool check(int x,int y)
{
	if (x >= 0 && y >= 0 && x < n&&y < m)
		return true;
	else
		return false;
}

void bfs1()
{
	point u, v;
	while (!q.empty())
	{
		u = q.front();
		q.pop();
		for (int i = 0; i < 8; i++)
		{
			v.x = u.x + dir[i][0];
			v.y = u.y + dir[i][1];
			v.time = u.time + k;
			if (check(v.x, v.y) && !vis[v.x][v.y])
			{
				q.push(v);
				vis[v.x][v.y] = 1;
				time_[v.x][v.y] = v.time;
			}
		}
	}
}

bool bfs2()
{
	point u, v;
	while (!q.empty())
	{
		u = q.front();
		q.pop();
		for (int i = 0; i < 4; i++)
		{
			v.x = u.x + dir[i][0];
			v.y = u.y + dir[i][1];
			v.time = u.time + 1;
			if (check(v.x, v.y) && v.time < time_[v.x][v.y]&&!vis1[v.x][v.y])
			{
				if (map[v.x][v.y] == 't')
				{
					time1 = v.time;
					return true;
				}
				vis1[v.x][v.y] = 1;
				q.push(v);
			}
		}
	}
	return false;
}
int main()
{
	while (~scanf("%d%d%d", &n, &m, &k))
	{
		int num = 0;
		if (!n&&!m&&!k)
			break;
		while (!q.empty())
			q.pop();
		memset(vis, 0, sizeof(vis));
		memset(vis1, 0, sizeof(vis1));
		for (int i = 0; i < n; i++)
		{
			scanf("%s", map[i]);
		}

		point u,v;
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < m; j++)
			{
				if (map[i][j] == 'f')
				{
					time_[i][j] = 0;
					vis[i][j] = 1;
					q.push(point{ i, j,0 });
					num++;
				}
				if (map[i][j] == 's')
				{
					u.x = i; u.y = j; u.time = 0;
					vis1[u.x][u.y] = 1;
				}
				if (map[i][j] == 't')
				{
					v.x = i; v.y = j;
				}
			}
		}
		if (num == 0)//注意可能没有火!!!!之前比赛的时候死在了这里
		{
			time1 = abs(v.x - u.x) + abs(v.y - u.y);
			printf("%d\n", time1);
			continue;
		}
		
		bfs1();
		while (!q.empty())
			q.pop();
		
		q.push(u);
		if (bfs2())
			printf("%d\n", time1);
		else
			printf("Impossible\n");
	}
	return 0;
}

/**********************************************************************
	Problem: 2031
	User: leo6033
	Language: C++
	Result: AC
	Time:12 ms
	Memory:2308 kb
**********************************************************************/