【题目】

Description

Download as PDF

Background

Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

The Problem

Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent a box tex2html_wrap_inline40 (length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze properties of the box such as the sum of its dimensions.

In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longest nesting string of boxes, that is a sequence of boxes tex2html_wrap_inline44 such that each box tex2html_wrap_inline46 nests in box tex2html_wrap_inline48 ( tex2html_wrap_inline50 .

A box D = ( tex2html_wrap_inline52 ) nests in a box E = ( tex2html_wrap_inline54 ) if there is some rearrangement of the tex2html_wrap_inline56 such that when rearranged each dimension is less than the corresponding dimension in box E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).

For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E = (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.

Formally, we define nesting as follows: box D = ( tex2html_wrap_inline52 ) nests in box E = ( tex2html_wrap_inline54 ) if there is a permutation tex2html_wrap_inline62 of tex2html_wrap_inline64 such that ( tex2html_wrap_inline66 ) ``fits'' in ( tex2html_wrap_inline54 ) i.e., if tex2html_wrap_inline70 for all tex2html_wrap_inline72 .

The Input

The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on the same line.)

This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. The tex2html_wrap_inline82 line in the sequence ( tex2html_wrap_inline84 ) gives the measurements for the tex2html_wrap_inline82 box.

There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length of that nesting string (the number of boxes in the string).

In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

The Output

For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost'' box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.

The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).

If there is more than one longest nesting string then any one of them can be output.

Sample Input

5 2
3 7
8 10
5 2
9 11
21 18
8 6
5 2 20 1 30 10
23 15 7 9 11 3
40 50 34 24 14 4
9 10 11 12 13 14
31 4 18 8 27 17
44 32 13 19 41 19
1 2 3 4 5 6
80 37 47 18 21 9

Sample Output

5
3 1 2 4 5
4
7 2 5 6

【题意】

给n维图形,它们的边长是{d1,d2,d3...dn},  对于两个n维图形,如果满足其中一个的所有边长按照任意顺序都一一对应小于另一个的边长,那么就锁可以嵌套到另一个。 例如a{1,2}, b{2,3},  a所有边长都已一一对应小于b的边长,所以a能嵌套于b。

给k个n维图形,求它们最多可以连续嵌套多少个。

【解题思路】记忆化搜索or最长上升子序列!!!

首先要判断两个图形是否可以嵌套,只需要把所有图形边长都按照从小到达排好序,那么对于a,b两个,只要按顺序一一比较它们的边数,如果满足所有ai<bi,就所以a能嵌套于b。

然后,就是解法,这题有两种解法。


第一种就是所谓的用记忆化搜索求DAG模型(详见《算法入门经典》p161).

我们可以用图的邻接矩阵来表示所有的关系,a“可嵌套于”b,那么就是G[a][b]=1。然后这个问题就可以转化成求这张图的一个最长路径长度是多少。


第二种方法,假设a可嵌套于b用a<b来表示,那么最长的一串就是a<b<c<d<e..., 可以看出非常像是一个“最长递增子序列”, 这里的“递增”是指“维度”递增。

【AC代码,记忆化搜索版本,最长上升子序列和这个差不太多】
/****记忆化搜索****/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

int G[32][32],arr[32][12];
int dis[32],n,k;
bool ***;
//judge arr[a] and arr[b] small or big.
inline bool judge(int a,int b)
{
    for(int i=0; i<k; i++)
    {
        if(arr[a][i]<=arr[b][i])return false;
    }
    return true;
}
int dfs(int i)
{
    if(dis[i]!=-1)return dis[i];
    int &ans=dis[i]=1;
    for(int j=0; j<n; j++)
    {
        if(G[i][j])
        {
            ans= max(ans,dfs(j)+1);
        }
    }
    return ans;
}
void Print_Path(int pos)
{
    if(***)printf(" %d",pos+1);
    else
    {
        printf("%d",pos+1);
        ***=true;
    }
    for(int j=0; j<n; j++)
    {
        if(G[pos][j]&&dis[j]+1==dis[pos])
        {
            Print_Path(j);
            break;
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<k; j++)
            {
                scanf("%d",&arr[i][j]);
            }
            sort(arr[i],arr[i]+k);
        }
        memset(G,0,sizeof(G));
        for(int i=0; i<n-1; i++)
        {
            for(int j=i+1; j<n; j++)
            {
                if(judge(i,j))        G[j][i]=1;
                else if(judge(j,i))   G[i][j]=1;
            }
        }
        memset(dis,-1,sizeof(dis));
        int ans=-1,pos;
        for(int i=0; i<n; i++)
        {
            int t=dfs(i);
            if(t>ans)
            {
                ans=t;
                pos=i;
            }
        }
        printf("%d\n",ans);
        ***=false;
        Print_Path(pos);
        printf("\n");
    }
    return 0;
}