Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

题意:找两个相距最远的点的距离

题解:树的直径,模板题,详细请看代码。

 

#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
const int MAX = 10000+10;
int tot,len,point;
struct hh{
	int to,nt,w;
}a[MAX];
int head[MAX],vis[MAX],dis[MAX];
void init(){
	memset(head,-1,sizeof(head));
	tot=0;
}
void add(int u,int v,int w){//建图模板
	a[tot].to=v;
	a[tot].w=w;
	a[tot].nt=head[u];
	head[u]=tot++;
}
void bfs(int s){
	queue<int> q;
	memset(dis,0,sizeof(dis));
	vis[s]=1;
	q.push(s);
	while(!q.empty()){
		int x=q.front();
		q.pop();
		for (int i = head[x]; ~i;i = a[i].nt){
			int y=a[i].to;
			if(!vis[y]){
				dis[y]=dis[x]+a[i].w;
				if(len<dis[y]){//找最远距离
					len=dis[y];
					point=y;
				}
				vis[y]=1;
				q.push(y);
			}
		}
	}
}
int main(){
	init();
	int x,y,z;
	while(cin >> x >> y >> z){
		add(x,y,z);
		add(y,x,z);
	}
	len=0;
	bfs(1);//随意一个点,用这个点找到最远点,保证有这个点就可以
	len=0;
	memset(vis,0,sizeof(vis));
	bfs(point);//找最远距离
	cout << len << endl;
	return 0;
}