N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0
Sample Output
1 1 1
3 2 1
题意:中文题,比较好理解,不解释。
题解:树状数组,区间更新,单点求值,典型题。模板题!!!
C++:
#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 1e+5+10;
int a[MAX];
int t;
int lowbit(int x){//模板写法
return x&-x;
}
int query(int x){//查询
int sum=0;
while(x){
sum+=a[x];
x-=lowbit(x);
}
return sum;
}
void add(int x,int v){
while(x<=t){
a[x]+=v;
x+=lowbit(x);
}
}
void update(int x,int y,int v){//更新
add(x,v);
add(y+1,-v);
}
int main(){
while(cin >> t,t){
memset(a,0,sizeof(a));
int w=t;
while(w--){
int x,y;
cin >>x >> y;
update(x,y,1);
}
for (int i = 1; i <= t;i++){
if(i!=t) cout << query(i) << " " ;
else cout << query(i) << endl;
}
}
return 0;
}
Java:
import java.util.*;
public class Main {
static Scanner cin = new Scanner(System.in);
static int n,m;
static int [] a;
static int lowbit(int x) {
return x&(-x);
}
static int query(int x) {
int sum=0;
while(x!=0) {
sum+=a[x];
x-=lowbit(x);
}
return sum;
}
static void add(int x,int v) {
while(x<=n) {
a[x]+=v;
x+=lowbit(x);
}
}
static void update(int x,int y,int v) { // 区间更新,更新区间开头和区间结尾后一个就可以。
add(x,v);
add(y+1,-v);
}
public static void main(String[] args){
while(cin.hasNext()) {
n = cin.nextInt();
a = new int[n+2];
if(n==0) break;
for (int i = 1; i <= n;i++) {
int x = cin.nextInt();
int y = cin.nextInt();
update(x,y,1);
}
for (int i = 1; i <= n;i++) {
if(i!=1) System.out.print(" "+query(i));//单点求值
else System.out.print(query(i));//单点求值
}
System.out.println();
}
}
}