You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

 

从终点向起点递推,每个点处的期望依赖它靠近终点一侧的6个点。

设f(i):位置i处出发的期望。

f(i)=1/6*Σf(j),j∈[i+1,i+6]。距终点不足6处特殊处理一下。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

int t,n,a[105];
double f[105];

int main()
{
	//freopen("input.in","r",stdin);
	cin>>t;
	for(int k=1;k<=t;k++)
	{
		cin>>n;
		for(int i=1;i<=n;i++)cin>>a[i];
		f[n]=a[n];
		for(int i=1;i<=6 && n-i>=1;i++)
		{
			double sum=0;
			for(int j=n-i+1;j<=n;j++)sum+=f[j];
			f[n-i]=a[n-i]+sum/i;
		}
		for(int i=n-7;i>=1;i--)
		{
			double sum=0;
			for(int j=i+1;j<=i+6;j++)sum+=f[j];
			f[i]=a[i]+sum/6;
		}
		printf("Case %d: %.8f\n",k,f[1]);
	}
	return 0;
}