Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input

2
3
4

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

题意:
求n^n最右边的那位数(即个位数)
快速幂,逢乘%10就OK了

#include<bits/stdc++.h>
using namespace std;
long long f(long long a,long long b){
	long long s=1;
	while(b){
		if(b&1){
			s%=10;
			a%=10;
			s*=a;
		}
		a%=10;
		a*=a;
		b>>=1;
	}
	return s%10;
}
int main(){
	int T,x;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&x);
		printf("%lld\n",f(x,x));
	}
	return 0;
}