0-1背包

Bone Collector

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

 Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

Input

 The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

 One integer per line representing the maximum of the total value (this number will be less than 231).
 

Example Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Example Output

14

Hint

Author

#include <iostream>
#include<bits/stdc++.h>
using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
    int n,v;
    scanf("%d%d",&n,&v);
    int g[3000]={0},w[3000],tj[3000];
    for(int i=1;i<=n;i++)
    scanf("%d",&w[i]);
    for(int j=1;j<=n;j++)
    scanf("%d",&tj[j]);
        for(int i=1; i<=n; i++)
        {
            for(int j=v; j>=1; j--) //j代表当前的背包容量
            {
                if(tj[i]<=j)//假如第i件物品可以放进
                {
                    g[j] = max(g[j],g[j-tj[i]]+w[i]);//腾出背包,并依据其价值判断是否放进
                }
            }
        }
    printf("%d\n",g[v]);

    }
    return 0;
}