Best Cow Line

Time Limit: 1000MS Memory Limit: 65536K

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single initial (‘A’…‘Z’) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’…‘Z’) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

思路:

题目是要求出最小的字典序的字符串,所以每次判断头和尾的字典序大小,将字典序小输出,假如两个一样的话,则按照头的下一个,尾的前一个进行判断,因为删除了头,头的后面一个才能进行判断,尾也是这个道理,代码的话可以直接使用模板库erase删除也可以用设置左右值每次左+1或者右-1,在poj在如果代码中右值right = s.size() - 1会wa,改成n - 1就行了,在输出的时候每输出80个换一行,题目有说(原来没看见,提交都是PE)。

#include <iostream>
#include <cstdio>
using namespace std;
int main() {
	int n;
	char s[2010];
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
        getchar();
        scanf("%c", &s[i]);
	}
	int left = 0, right = n - 1, count = 0;
	while (left <= right) {
		bool book = false;
		for (int i = 0; left + i <= right; i++) {
			if (s[left + i] < s[right - i]) {
				book = true;
				break;
			}
			else if (s[left + i] > s[right - i]) break;
		}
		if (book == true) cout << s[left++];
		else cout << s[right--];
		count++;
		if (count % 80 == 0) cout << endl;
	}
	cout << endl;
	return 0;
}