题目来源:http://poj.org/problem?id=1861
Description
Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.
Input
The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.
Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.
Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1
Sample Output
1
4
1 2
1 3
2 3
3 4
因为要记录一下路径,因此我用的并查集;
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<stack>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
#define da 10000000
#define xiao -10000000
#define clean(a,b) memset(a,b,sizeof(a))
int n,m,sum,max;
struct ac{
int x,y;
int l;
int biaoji; //标记道路
}kind[15005];
int prince[1005]; //没个人的首领,里面的元素为首领
void intt() //自成一派
{
for(int i=0;i<=n;++i)
prince[i]=i;
}
int find(int x) //找老大
{
int i=x,j,can;
while(prince[x]!=x)
x=prince[x];
/*while(i!=x); // .rar;//路径压缩
{
can=prince[i];
prince[i]=x;
i=can;
}*/
return x;
}
void mix(int a,int b) //合并两排
{
int aa=find(a);
int bb=find(b);
if(aa!=bb) //老大不同
prince[aa]=bb; //合并
}
int cmp(ac a,ac b)
{
return a.l<b.l; //升序排长度
}
int main()
{
scanf("%d%d",&n,&m);
int i,j;
for(i=0;i<m;++i)
scanf("%d%d%d",&kind[i].x,&kind[i].y,&kind[i].l);
intt();
sort(kind,kind+m,cmp);
sum=0;
int can,lu=0;
for(i=0;i<m;++i)
{
ac e=kind[i];
if(find(e.x)!=find(e.y)) //首领不一样代表不连通
{
mix(e.x,e.y); //将它连通
sum=sum+e.l; //生成树长度增加
can=i;
lu++;
kind[i].biaoji=1; //标记,代表这条路被使用过
}
}
printf("%d\n%d\n",kind[can].l,lu);
for(i=0;i<m;++i)
{
if(kind[i].biaoji==1)
printf("%d %d\n",kind[i].x,kind[i].y); //输出对应的路径
}
}