Stay Real

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)

Problem Description

In computer science, a heap is a specialized tree-based data structure which is essentially an almost complete tree that satisfies the heap property: in a min heap, for any given node C, if P is a parent node of C, then the key(the value) of P is less than or equal to the key of C. The node at the ``top’’ of the heap(with no parents) is called the root node.

Usually, we may store a heap of size n in an array h1,h2,…,hn, where hi denotes the key of the i-th node. The root node is the 1-th node, and the parent of the i(2≤i≤n)-th node is the ⌊i2⌋-th node.

Sunset and Elephant is playing a game on a min heap. The two players move in turns, and Sunset moves first. In each move, the current player selects a node which has no children, adds its key to this player’s score and removes the node from the heap.

The game ends when the heap is empty. Both players want to maximize their scores and will play optimally. Please write a program to figure out the final result of the game.

Input

The first line of the input contains an integer T(1≤T≤10000), denoting the number of test cases.

In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of nodes.

In the second line, there are n integers h1,h2,…,hn(1≤hi≤109,h⌊i2⌋≤hi), denoting the key of each node.

It is guaranteed that ∑n≤106.

Output

For each test case, print a single line containing two integers S and E, denoting the final score of Sunset and Elephant.

Sample Input

1
3
1 2 3

Sample Output

4 2

题意:

给你一个最小堆,有两个人选择最小堆中的叶节点最大。

思路:

选择最大,那么就表示每次选择数组中没被选过的最大的那个数就行了,因为最小堆的话,父节点总是小于子结点,所以每次选择最大的子结点,就等于选择剩下的最大的数。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;
int main() {
    ll n, t;
    ll a[100010];
    scanf("%lld", &t);
    while (t--) {
        bool flag = false;
        ll sums = 0, sume = 0;
        scanf("%lld", &n);
        for (int i = 0; i < n; i++) scanf("%lld", &a[i]);
        sort(a, a + n);
        for (int i = n - 1; i >= 0; i--) {
            if (!flag) sums += a[i];
            else sume += a[i];
            flag = !flag;
        }
        printf("%lld %lld\n", sums, sume);
    }
    return 0;
}