题目链接:https://pintia.cn/problem-sets/994805046380707840/problems/1111914599412858885
时间限制: 400 ms 内存限制: 64 MB

题目描述

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 I 和 me 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

解题思路

按照题上说的要求处理输出就行了,就是有点麻烦。

/*
*@Author:   lzyws739307453
*@Language: C++
*/
#include <bits/stdc++.h>
using namespace std;
char s1[]="can you";
char s2[]="could you";
int main() {
    char str[1005], str1[1005];
    int i, l1, t, k;
    scanf("%d%*c", &t);
    while (t--) {
        i = k = 0;
        memset(str1, 0, sizeof(str1));
        while (scanf("%c", &str[i]), str[i++] != '\n');
        str[--i] = '\0';
        printf("%s\nAI: ", str);
        while (i && str[--i] == ' ');
        l1 = i + 1, i = 0;
        while (str[i++] == ' ');
        for (--i; i < l1; i++) {
            if (str[i] != ' ') {
                if (isupper(str[i]) && str[i] != 'I')
                    str[i] += 'a' - 'A';
                str1[k++] = str[i];
            }
            else {
                if (isalpha(str[i + 1]) || isdigit(str[i + 1]))
                    str1[k++] = str[i];
            }
        }
        for (i = 0; i < k; i++) {
            if (str1[i] == '?')
                printf("!");
            else if (str1[i] == 'I' && (!i || !isalpha(str1[i - 1])) && !isalpha(str1[i + 1]))
                printf("you");
            else if (str1[i] == 'm' && str1[i + 1] == 'e' && (!i || !isalpha(str1[i - 1])) && !isalpha(str1[i + 2])) {
                printf("you");
                i++;
            }
            else if (str1[i] == 'c' && (!i || !isalpha(str1[i - 1])) && i <= k - 7) {
                int j;
                for (j = 0; j < 7; j++)
                    if (str1[i + j] != s1[j])
                        break;
                if (j >= 7 && !isalpha(str1[i + 7])) {
                    printf("I can");
                    i += 6;
                }
                else if (i <= k - 9) {
                    for (j = 0; j < 9; j++)
                        if (str1[i + j] != s2[j])
                            break;
                    if (j >= 9 && !isalpha(str1[i + 9])) {
                        printf("I could");
                        i += 8;
                    }
                    else printf("%c", str1[i]);
                }
                else printf("%c", str1[i]);
            }
            else printf("%c", str1[i]);
        }
        printf("\n");
    }
    return 0;
}