题干:

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source

USACO 2006 November Gold

 

题目大意:

      给一块长木板,现要将其锯成n段,共需锯n-1次,每次锯的代价为所锯木板的长度,求最小总代价。

解题报告:

         若把木板切割过程画成一个树的话,根就是总长度,枝叶是n段切割后的木板长度,显然费用就是所有的节点的和,所以也就是 叶节点的大小*节点深度,所以我们希望深度越大的木板越短越好。所以逆向生成一棵树,从叶节点开始一次合并最小和次小木板直到生成一棵树。或用交换排序贪心法去思考。

 

AC代码:

#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
priority_queue<int,vector<int>,greater<int> >que;//小根堆 
int n;
long long ans;
int main(){
    scanf("%d",&n);
    for(int i=1,x;i<=n;i++){
        scanf("%d",&x);
        que.push(x);
    }
    for(int i=1,x,y;i<n;i++){
        x=que.top();que.pop();
        y=que.top();que.pop();
        ans+=x+y;
        que.push(x+y);
    }
    printf("%lld\n",ans);
    return 0;
}

注意一个错误代码:

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#define ll long long
using namespace std;
ll a[200000];

int main()
{
	int n;
	cin>>n;
	ll sum = 0,ans = 0;
	for(int i = 1; i<=n; i++) {
		scanf("%lld",&a[i]);
		sum += a[i];
	}
	sort(a+1,a+n+1);
	if(n == 1){
		printf("0\n");return 0;
	}
	ans = a[1] + a[2];
	for(int i = 3; i<=n; i++) {
		ans += ans + a[i];
	}
	printf("%lld\n",ans);
	return 0 ;
 } 

错误原因:直接把刚求出来的ans接着带入求了,这样是不对的!因为这个ans不一定被接着用。。 

总结:

有坑:注意这题说5e4 * 2e4的数据量貌似刚刚好1e9,貌似可以int,但是这题必须longlong才能过!原因自己想。(其实ans只要开longlong就可以了)