Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36704    Accepted Submission(s): 18014


 

Problem Description

Give you the width and height of the rectangle,darw it.

 

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

 

Output

For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

 

Sample Input

3  2

Sample Output

+---+
|   |
|   |
+---+

题意:

      根据输入输出相应的图形。

      别忘了最后再空出一行。

代码:

#include<stdio.h>
int main()
{
	int m,n,i,j;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		printf("+");
		for(i=1;i<=m;i++)
			printf("-");
		printf("+\n");
		for(i=1;i<=n;i++)
		{
			printf("|");
			for(j=1;j<=m;j++)
				printf(" ");
			printf("|\n");
		}
		printf("+");
		for(i=1;i<=m;i++)
			printf("-");
		printf("+\n");
		printf("\n");
	}
}