题干:

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

 

题目大意:

    给你一个字符串,求这个字符串到第i个字符为止的子字符串的循环节的次数,输出i和循环次数。

解题报告:

   运用next数组可以直接出结果、、

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const int MAX = 2e6 + 5;
char s[MAX];
int Next[MAX],len;
void getnext() {
	Next[0] = -1;
	int k = -1,j = 0;
	int len = strlen(s);
	while(j < len) {
		if(k == -1 || s[k] == s[j]) {
			k++,j++;
			Next[j] = k;
		} else k = Next[k];
	}
}
int main() {
	int n,iCase = 0;
	while(~scanf("%d",&n)) {
		if(n == 0) break;
		scanf("%s",s);
		getnext();
		printf("Test case #%d\n",++iCase);
		for(int i=2; i<=n; i++) {
			int tmplen=i-Next[i]; //循环节长度
			if(Next[i]>0 && i % tmplen == 0) 
				printf("%d %d\n",i,i/tmplen);
		}
		printf("\n");
	}
	return 0;
}