Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

题目大意:

先输入一个数字n表示操作次数,当n为0时结束。接下来输入要去的层数,每上一层需要6秒,下一层需要4秒,每开门一次需要5秒。所需开门次数为n-1。

c++:

#include <iostream>
using namespace std;
int main()
{
    int a[110];           //a数组用来存放要去的层数
    int b,c,d,e,f,g;      //b表示操作次数,g是所需时间
    while(cin>>b)
    {
        g=0;
        if(b==0)
            break;
        for(c=0;c<b;c++)
        {
            cin>>a[c];
        }
        d=0;
        g=g+a[0]*6;
        for(c=0;c<b-1;c++)
        {
            if(a[c+1]>a[c])
            {
                g=g+(a[c+1]-a[c])*6;
            }
            else
            {
                g=g+(a[c]-a[c+1])*4;
            }
        }
        g=g+5*b;
        cout<<g<<endl;
    }
    return 0;
}