Problem Description

In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training. 

Obviously many people don’t want more training, so the clever leader didn’t write down their words such as ”Yes” or ”No”. Instead, he let everyone choose a positive integer ai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1) and k(0≤k< m), and regard those people whose number is exactly k modulo m as ”Yes”, while others as ”No”. If the number of ”Yes” is not less than ”No”, the leader can have chance to offer more training.

Please help the team leader to find such pair of m and k.

Input

The first line of the input contains an integer T(1≤T≤15), denoting the number of test cases.

In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are n distinct integers a1,a2,…,an(1≤ai≤109), denoting the number that each person chosen.

Output

For each test case, print a single line containing two integers m and k, if there are multiple solutions, print any of them.

Sample Input



23 3 18 8 13 9

Sample Output

5 3

题目大意:

这是一个签到题,对2取余,看奇偶个数,奇数多输出2 1,偶数多输出2 0,一样多二者皆可。

c++

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t,n;
    int a[100005];
    scanf("%d",&t);
    while(t--){
        int ans=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            if(a[i]%2==1)
                ans++;
        }
        if(ans>n/2){
            printf("2 1\n");
        }
        else{
            printf("2 0\n");
        }
    }
    return 0;
}