题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
Problem solving report:
Description: n个骨骼和一个容量为v的背包,每个骨骼都有一定的骨骼值和体积,问能得到的最大的骨骼值。
Problem solving: 简单的01背包。
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
struct edeg {
int v, w;
}p[1005];
int main()
{
int t, n, v, dp[1002];
scanf("%d", &t);
while(t--)
{
scanf("%d%d", &n, &v);
memset(dp,0,sizeof(dp));
for (int i = 0; i < n; i++)
scanf("%d", &p[i].w);
for (int i = 0; i < n; i++)
scanf("%d", &p[i].v);
for (int i = 0; i < n; i++)
for (int j = v; j >= p[i].v; j--)
dp[j] = max(dp[j], dp[j - p[i].v] + p[i].w);
printf("%d\n", dp[v]);
}
return 0;
}