Til the Cows Come Home
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 46982   Accepted: 15988

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source



题意:

裸SPFA.....

那个啊哈算法里面的SPFA的模板  打了之后会T....

然后翻红书的模板..发现它用了vector来维护优先队列- -可惜还是不太会。。


代码:

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
struct node {
	int next;
	int v;
	int val;
}edge[100001];
int head[10001],n,m,visit[10001],cnt,d[10001];
queue<int> q;
void add(int x,int y,int z)
{
	edge[++cnt].v=y;
	edge[cnt].next=head[x];
	edge[cnt].val=z;
	head[x]=cnt;
}
int main()
{
	int x,y,z;
	while(scanf("%d%d",&n,&m)==2)
	{
		memset(head,-1,sizeof(head));
		memset(d,214546,sizeof(d));
		memset(visit,0,sizeof(visit));
		while(!q.empty() ){
			q.pop() ;
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d%d",&x,&y,&z);
			add(x,y,z);
			add(y,x,z);
		}
		q.push(1);
		visit[1]=1;
		d[1]=0;
		while(!q.empty())
		{
			int a=q.front();
			q.pop();      
			visit[a]=0;
			for(int i=head[a];i!=-1;i=edge[i].next)
			{
				if(d[edge[i].v]>d[a]+edge[i].val)
				{
				   if(!visit[edge[i].v]){
				       d[edge[i].v]=d[a]+edge[i].val;
				       q.push(edge[i].v);
				      visit[edge[i].v]=1;
				   }
				   else {
				       d[edge[i].v]=d[a]+edge[i].val;
				   }
				}
			}
		}
		printf("%d ",d[m]);
	}
	return 0;
}

//啊哈算法 超时的算法
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdlib>
using namespace std;
#define N 1005
int u[N],v[N],w[N];
int first[N],next[N];
int dis[N]={0},book[N]={0};
int que[N]={0},head=1,tail=1;
int inf=0x3f3f3f;

int main()
{
	int t,n;
	while(scanf("%d%d",&t,&n)!=EOF)
	{
		int k;
		for(int i=1;i<=n;i++)
		{
			dis[i]=inf;
			book[i]=0;
			first[i]=-1;
		}
		dis[1]=0;
		for(int i=1;i<=t;i++)
		{
			scanf("%d%d%d",&u[i],&v[i],&w[i]);
			next[i]=first[u[i]];
			first[u[i]]=i;	
		}
		//入队 
		que[tail]=1;tail++;
		book[1]=1;
		while(head<tail)
		{
			k=first[que[head]];
			while(k!=-1)
			{
				if(dis[v[k]]>dis[u[k]]+w[k])
				{
					dis[v[k]]=dis[u[k]]+w[k];
					if(book[v[k]]==0)
					{
						que[tail]=v[k];
						tail++;
						book[v[k]]=1;
					}
				}
				k=next[k];
			}
		book[que[head]]=0;
		head++;
		}
		printf("%d\n",dis[n]);
	}
	return 0;
}