题目链接:http://nyoj.top/problem/1241

  • 内存限制:64MB 时间限制:2000ms

题目描述

One day , Wang and Dong in the Dubai desert expedition, discovered an ancient castle. Fortunately, they found a map of the castle.The map marks the location of treasures.

They agreed to distribute the treasures according to the following rules:

Wang draws a horizontal line on the map and then Dong draws a vertical one so that the map is divided into 4 parts, as show below. 

Wang will save the treasures in I and III ,while those situated in II and IV will be taken away by Dong. Wang first draw a horizontal line, Dong after the draw a vertical line.

They drew several pairs of  lines. For each pair, Wang wants to know the difference between their treasures.

It's guaranteed that all the reasures will lie on neither of the lines drew by them.

输入描述

the first line contains two integers N and M, where N is the number of treasures on the map and M indicates how many times they are going to draw the lines. The 2nd to (N+1)-th lines Xi, Yi contain the co-ordinates of the treasures and the last M lines consist of the M pairs integers (X, Y) which means that the two splitting lines intersect at point (X, Y).
(0 < N, M ≤ 100,  0 ≤ Xi, Yi, X,Y ≤ 1000)

输出描述

Output contains M lines,a single line with a integer,the difference described above.

样例输入

10 3 
29 22
17 14 
18 23
3 15
6 28
30 27
4 1
26 7
8 0
11 21
2 25
5 10
19 24

样例输出

-6
4
4

解题思路

题意:给出N个宝藏坐标,然后给出M个画线的交点坐标,输出每次画线后区域(I+III)-(II+IV)的结果。
思路:直接判断就行了。

#include <bits/stdc++.h>
using namespace std;
struct edge {
    int x, y;
}e[105];
int main() {
    int n, m, x, y;
    scanf("%d%d", &n, &m);
    for (int i = 0; i < n; i++)
        scanf("%d%d", &e[i].x, &e[i].y);
    while (m--) {
        int a = 0, b = 0;
        scanf("%d%d", &x, &y);
        for (int i = 0; i < n; i++) {
            if (e[i].x > x && e[i].y > y || e[i].x < x && e[i].y < y)
                a++;
            else b++;
        }
        printf("%d\n", a - b);
    }
    return 0;
}