GCD

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Given 5 integers: a, b, c, d, k, you’re to find x in a…b, y in c…d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you’re only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

Output

For each test case, print the number of choices. Use the format in the example.

Sample Input

2
1 3 1 5 1
1 11014 1 14409 9

Sample Output

Case 1: 9
Case 2: 736427

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

题意:

在1<= x <= b && 1 <= y <= d中,有多少个gcd(x, y)。

思路:

莫比乌斯的模板题,需要注意的是最后要减去重复的数。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 100010;
ll modn[maxn], prime[maxn];
bool book[maxn] = {false};
void GetModn() {
    int cnt = 0;
    modn[1] = 1;
    for (int i = 2; i < maxn; i++) {
        if (!book[i]) {
            modn[i] = -1;
            prime[cnt++] = i;
        }
        for (int j = 0; j < cnt && prime[j] * i < maxn; j++) {
            int x = prime[j];
            book[i * x] = true;
            if (i % x == 0) {
                modn[i * x] = 0;
                break;
            } else modn[i * x] = -modn[i];
        }
    }
}
int main() {
    ios::sync_with_stdio(false);
    GetModn();
    int t;
    scanf("%d", &t);
    for (int Case = 1; Case <= t; Case++) {
        ll a, b, c, d, k;
        scanf("%lld %lld %lld %lld %lld", &a, &b, &c, &d, &k);
        printf("Case %d: ", Case);
        if (k == 0) {
            printf("0\n");
            continue;
        }
        b /= k;
        d /= k;
        ll ans1 = 0, ans2 = 0;
        for (int i = 1; i <= min(b, d); i++) ans1 += modn[i] *  (b / i) * (d / i);
        for (int i = 1; i <= min(b, d); i++) ans2 += modn[i] * (min(b, d) / i) * (min(b, d) / i);
        ans1 -= ans2 / 2;
        printf("%lld\n", ans1);
    }
    return 0;
}