Parity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6126    Accepted Submission(s): 4578

 

Problem Description

A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.

 

Input

The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.

Output

Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').

 

Sample Input

101e 010010o 1e 000e 110100101o #

 

Sample Output

1010 0100101 11 0000 1101001010

题意:输入字符串,统计1的个数,若字符串以e结尾,则将该字符替换成1或0,使字符串中1的数量为偶数;若字符串以o结尾,则将该字符替换成1或0,使字符串中1的数量为奇数

代码:

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
 
int main()
{
	string a;
	int n,i;
	while(1)
	{
		cin>>a;
		if(a=="#")
			break;
		int s=0;
		for(i=0;i<a.length()-1;i++)
		{
			if(a[i]=='1')
				s++;
			cout<<a[i];
		}
		if(a[a.length()-1]=='e')
		{
			if(s%2==1)
				cout<<1<<endl;
			else
				cout<<0<<endl;
		}
		else
		{
			if(s%2==1)
				cout<<0<<endl;
			else
				cout<<1<<endl;
		}
	}
	return 0;
}