题干:

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

Output

Output should contain the maximal sum of guests' ratings. 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

解题报告:

    树形dp解决,话说竟然开2e7的数组还不炸、、

AC代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int n;
int head[6000 + 5],in[6000 +5];
int val[6000 + 5];
int dp[6000 +5][2];//0代表不选; 1代表选 
int top = 0;
struct Node {
	int to;
	int ne;
} e[20000005];
void add(int u,int v) {
	e[++top].to = v;
	e[top].ne = head[u];
	head[u] = top;
}
void work(int cur) {
	dp[cur][1] = val[cur];
	for(int i = head[cur]; i!=-1;i=e[i].ne) {
		work(e[i].to);
		dp[cur][0] += max(dp[e[i].to][1] , dp[e[i].to][0]);
		dp[cur][1] += dp[e[i].to][0];
	}
	
}
int main()
{
	int a,b;
	while(cin>>n) {
		memset(head,-1,sizeof(head));
		memset(in,0,sizeof(in));
		top=0;
		for(int i = 1; i<=n; i++) {
			scanf("%d",&val[i]);
			dp[i][0]=0;dp[i][1]=0;
		}
		while(scanf("%d%d",&a,&b)) {
			if(a == 0 && b == 0) break;
			add(b,a);in[a]++;
		}
		for(int i = 1; i<=n; i++) {
			if(in[i] == 0) {
				work(i);
				printf("%d\n",max(dp[i][1],dp[i][0]));break;
			}
		}
	}
	
	return 0 ;
}