Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R  AB, C  AB, R  BA and C  BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10  3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10  -2<=rate<=10  2, 0<=commission<=10  2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10  4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
有多种汇币,汇币之间可以交换,这需要手续费,当你用100A币
交换B币时,A到B的汇率是29.75,手续费是0.39,那么你可以得到
(100 - 0.39) * 29.75 = 2963.3975 B币。问s币的金额经过交换最终
得到的s币金额数能否增加
货币的交换是可以重复多次的,所以我们需要找出是否存在
正权回路,且最后得到的s金额是增加的
怎么找正权回路呢?(正权回路:在这一回路上,顶点的权值能不断增加即能一直进行松弛)

直接SPFA就好~~
//Asimple
#include <iostream>
#include <sstream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <set>
#include <map>
#include <string>
#include <queue>
#include <limits.h>
#include <time.h>
#define mod 100000
#define CLS(a, v) memset(a, v, sizeof(a))
using namespace std;
typedef long long ll;
const int maxn = 100+5;
ll n, m, num, T, k, len, ans, sum, x, y, z;
double c[maxn][maxn], r[maxn][maxn];
double dis[maxn], di;
double a_bc, b_ac, a_br, b_ar;void solve(int s){
    queue<int> q;
    bool vis[maxn];
    CLS(dis, 0);
    CLS(vis, false);
    q.push(s);
    dis[s] = di;
    vis[s] = true;
    while( !q.empty() ) {
        x = q.front();
        q.pop();
        vis[x] = false;
        for(int i=0; i<=n; i++) {
            if( dis[i]<(dis[x]-c[x][i])*r[x][i] ) {
                dis[i] = (dis[x]-c[x][i])*r[x][i];
                if( dis[s]>di ) {
                    cout << "YES" << endl;
                    return ;
                }
                if( !vis[i] ) {
                    vis[i] = true;
                    q.push(i);
                }
            }
        }
    }
    cout << "NO" << endl;
}

void input() {
    ios_base::sync_with_stdio(false);
    while( cin >> n >> m >> k >> di ) {
        for(int i=1; i<=n; i++) {
            for(int j=1; j<=n; j++) {
                r[i][j] = i==j?1:0;
                c[i][j] = 0;
            }
        }
        while( m -- ) {
            cin >> x >> y >> a_br >> a_bc >> b_ar >> b_ac;
            r[x][y] = a_br;
            r[y][x] = b_ar;
            c[x][y] = a_bc;
            c[y][x] = b_ac;
        }
        solve(k);
    }
}
 
int main(){
    input();
    return 0;
}