题目

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10 <math> <semantics> <mrow> <msup> <mn> 4 </mn> </msup> </mrow> <annotation encoding="application&#47;x&#45;tex"> ^4 </annotation> </semantics> </math>4​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10 <math> <semantics> <mrow> <msup> <mn> 5 </mn> </msup> </mrow> <annotation encoding="application&#47;x&#45;tex"> ^5 </annotation> </semantics> </math>5​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

分析

题目大意:给出一组提交数据及相关信息,排序后输出结果
这道题细节比较多:

  1. 排序是先按总分,再按解题数,再其次 id 序号,所以可能排序后,那些不被显示的,反而排在被显示但是总分为0的前面(因为总分初始化都是0,而id号不被显示的人更小一些),解决办法是把id序号初始到很大,当确定此人被显示,再把id序号"还"给他
  2. 不被显示的只有两种人:一道题也没提交的和一道题也没通过编译的,所以即使是提交得分为 0,也会被显示,解决方法是"还"id序号的时候计数器+1
  3. 某人某道题已经满分但是提交了多次,算正确一道题,解决方法是把所有得分读入完成后再确定正确题目数
#include<cstdio>
#include<algorithm>
#include<vector>

const int INIT = -2;  // 初始化 
const int NOPASS = -1;  // 未通过编译 
const int MAXID = 10005;  //最大ID 
using namespace std;

struct info{
	int id;    // id号 
	int ques[6];  // 每道题得分
	int sum;   // 总分 
	int solved;   // 答对题数 
};

// 定义sort 的排序规则 
bool cmp(info a,info b){
	if(a.sum != b.sum)
		return a.sum>b.sum;	
	if(a.solved != b.solved)
		return a.solved > b.solved;
	return a.id < b.id;
}


int main(){
	int N;  // 使用者总数
	int K;  // 问题总数
	int M;  // 提交总数 
	scanf("%d %d %d",&N,&K,&M);
	vector<info> user(N+1); // 使用者信息
	int Full[K+1];  // 记录问题总分 ,a[i] 表示第i道题的分数
	for(int i=1;i<=K;i++) 
		scanf("%d",&Full[i]);
	// 初始化信息 
	for(int i=1;i<N+1;i++){
		user[i].id = MAXID;  // 初始化成最大 
		user[i].sum = 0; 
		user[i].solved = 0;
		for(int j=1;j<K+1;j++) 
			user[i].ques[j] = INIT;
	}
	int use;  // 玩家编号 
	int question;  // 问题编号 
	int score;  // 得分 
	int listSum = 0; // 应该被输出总数 
	for(int i=0;i<M;i++){
		scanf("%d %d %d",&use,&question,&score);
		// 只要通过编译,该玩家就能被显示
		if(score >= 0 && user[use].id == MAXID){
			listSum++;
			user[use].id = use;
		} 
		// 分数有更大更新成更大 
		if(user[use].ques[question] < score){
			user[use].ques[question] = score;
		}
	}
	for(int i=1;i<N+1;i++)
		for(int j=1;j<K+1;j++){
			// 计算完全正确解题数 
			if(user[i].ques[j] == Full[j])
				user[i].solved++;
			// 计算总分 
			if(user[i].ques[j] != NOPASS && user[i].ques[j] != INIT)
				user[i].sum += user[i].ques[j];
		} 
	
	sort(user.begin()+1,user.end(),cmp);
	
	int preSum = user[1].sum;
	int preNum = 1;
	
	for(int i=1;i<=listSum;i++){ 
	    // 如果和上次分数不同,更新排名 
		if(preSum != user[i].sum){ 
			preNum = i;
			preSum = user[i].sum;
		} 
		printf("%d ",preNum);
		printf("%05d %d",user[i].id,user[i].sum);
		for(int j=1;j<K+1;j++){
			// 依旧初始化状态 
			if(user[i].ques[j] == INIT)
				printf(" -");
			else if(user[i].ques[j] == NOPASS)
				printf(" 0");
			else
				printf(" %d",user[i].ques[j]);
		}
		printf("\n");
	}
	return 0;
}