Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21318 Accepted Submission(s): 8724

Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~‘z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input
3
aaa
abca
abcde

Sample Output
0
2
5

题目大意:
给你一串序列,你只能在尾部加字符,为使得这个序列形成一个环(说不清直接拿例子说吧),为了使abca序列成一个环你需要在后面添加字符bc,这样首尾相连且一致,又如abcde你需要在后面添加abcde才能形成一个环,题目问你为了构成一个环你最少需要添加几个字符。

思路:我们可以先用kmp中的方法构建next数组,next[i]的值就是循环串前缀与后缀串相同的最大个数(事实上最少添加个数只与next【尾】有关,因为中间的next值无论你多大只要你到了串尾,一旦不相等,就是要添加再再尾部添加一个一模一样的串),然后用总串长减去这个循环串中前后缀最大相同个数,能够得到一个不循环串的长度(例如:abcdefabcd,我们需要在后面加ef使他循环,为此我们需要它前面那个串的长度),得到这个长度后用它减去next[串尾]就是我们要的答案,因为next[串尾]存的是最大前后缀相同个数,也就是说abcdef-abcd=2就是答案因为只需添加ef就能构成循环串,但是如果只是用不循环串长-最大前后缀相同个数可能会出现负数的情况例如:abcabca,答案应该是2,但是因为它循环了两次导致3(abc)-4(abca)=-1,实际上应该是3(abc)-1(a)=2,这时我们可以用模运算解决循环节>1的情况,只需要用next[串尾]%不循环串的长度就能解决问题。

代码:

#include<string>
#include<vector>
#include<stdio.h>
#include<iostream>
using namespace std;

string t;
vector<int> getnext(string t){
    vector<int>next(t.size());
    for(int i=1,k=0;i<t.size();i++){
        while(k>0&&t[i]!=t[k]){
            k=next[k-1];
        }
        if(t[i]==t[k]){
            next[i]=++k;
        }else{
            next[i]=k;
        }
    }
    return next;
}
void kmp(string t){
    vector<int>next=getnext(t);
    int len=t.size()-next[t.size()-1];
    if(next[t.size()-1]==0)printf("%d\n",t.size());//没有前后缀相同的存在,只能再尾部加一条一模一样的字符串
    else{
    	if(t.size()%len==0)printf("0\n");//每个前后缀刚好构成循环节 
    	else{
    		printf("%d\n",len-(next[t.size()-1]%len));
		}
	}
}
int main(){
    int T;
    std::ios::sync_with_stdio(false);
    scanf("%d",&T);
    while(T--){
        cin>>t;
        kmp(t);
    }
}