给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT….”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

c++

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char a[10050];
    int b,c,d,e=0,f=0,g=0;
    cin>>a;
    b=strlen(a);
    d=0;
    for(c=0;c<b;c++)
    {
        if(a[c]=='G'||a[c]=='g')
        {
            d++;
        }
        else if(a[c]=='P'||a[c]=='p')
        {
            e++;
        }
        else if(a[c]=='L'||a[c]=='l')
        {
            f++;
        }
        else if(a[c]=='T'||a[c]=='t')
        {
            g++;
        }
    }
    while(1)
    {
        while(d--)
        {
            if(d>=0)
            {cout<<'G';break;}
            break;
        }
        while(e--)
        {
            if(e>=0)
            {cout<<'P';break;}
            break;
        }
        while(f--)
        {
            if(f>=0)
            {cout<<'L';break;}
            break;
        }
        while(g--)
        {
            if(g>=0)
            {cout<<'T';break;}
            break;
        }
        if(d<=0&&e<=0&&f<=0&&g<=0)
        {
            break;
        }
    }
    cout<<endl;
    return 0;
}