Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:把一段木头分成n段,每分一次的费用等于所分木头的长度,求需要的最小费用;

思路:我们把一段木头分成两段,费用是肯定的,但为了使后面产生的费用尽可能少,我们应该尽可能的使这两段木头的长度相             等;因此我们可以反过来考虑,把n段木头合成一段木头所需的最小费用。这样可以用一个优先队列来维护,先把每段木               加入优先队列,每次取出最小的两个和并,再把新合并的加入队列,直到合并成一段。

 

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#define ll long long
#include<set>
#include<stack>
#include<cstring>
#include<string>
#include<queue>
using namespace std;
const int maxn=0x3f3f3f3f;

int main(){
    int n; scanf("%d",&n);
    int L[n+4];
    priority_queue<int,vector<int>,greater<int> > q;
    for(int i=1;i<=n;i++){
        scanf("%d",&L[i]);
        q.push(L[i]);
    }
    ll ans=0;
    while(q.size()>1){
        int x1=q.top();q.pop();
        int x2=q.top();q.pop();
        ans+=(x1+x2);
        q.push(x1+x2);
    }
    printf("%lld\n",ans);

    return 0;
}