Blocks

Time Limit: 1000MS Memory Limit: 65536K

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

思路:

矩阵快速幂的模板题,难得地方就是如何确立刚开始的矩阵,所以我就列一个方程吧:设ai是偶数的个数,bi是一奇一偶的个数,ci是无偶数的个数,所以就有
ai+1 = 2ai+bi
bi+1 = 2ai+2bi+2ci
ci+1 = 2bi+2ci
这样矩阵就出来了,没有的地方就补零就行了。

#include <iostream>
#include <vector>
using namespace std;
const int mod = 10007;
typedef long long ll;
typedef vector<int> vec;
typedef vector<vec> mat;
mat mul(mat a, mat b) {
	mat c(a.size(), vec(b[0].size()));
	for (int i = 0; i < a.size(); i++) {
		for (int j = 0; j < b[0].size(); j++) {
			for (int k = 0; k < b.size(); k++) {
				c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % mod;
			}
		}
	}
	return c;
}
mat pow(mat a, int n) {
	mat b(a.size(), vec(a[0].size()));
	for (int i = 0; i < a.size(); i++) b[i][i] = 1;
	while (n) {
		if (n & 1) b = mul(a, b);
		a = mul(a, a);
		n >>= 1;
	}
	return b;
}
int main() {
	int t, n;
	scanf("%d", &t);
	while (t--) {
		mat a(3, vec(3));
		scanf("%d", &n);
		a[0][0] = 2, a[0][1] = 1, a[0][2] = 0;
		a[1][0] = 2, a[1][1] = 2, a[1][2] = 2;
		a[2][0] = 0, a[2][1] = 1, a[2][2] = 2;
		a = pow(a, n);
		printf("%d\n", a[0][0]);
	}
	return 0;
}