【题目链接】

Problem Description

Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant’s QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m, say [l,l+m−1], and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=−1 and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count. Please write a program to figure out the answer.

Input

The first line of the input contains an integer T(1≤T≤2000), denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤107,5≤p,q,r,MOD≤109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD.
In the next line, there are k integers a1,a2,…,ak(0≤ai≤109), denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially.
The values ai are then produced as follows :

ai=(p×ai−1+q×i+r)modMOD

It is guaranteed that ∑n≤7×107 and ∑k≤2×106.

Output

Since the output file may be very large, let’s denote maxratingi and counti as the result of interval [i,i+m−1].
For each test case, you need to print a single line containing two integers A and B, where :

AB==∑i=1n−m+1(maxratingi⊕i)∑i=1n−m+1(counti⊕i)

Note that “⊕” denotes binary XOR operation.

Sample Input

1
10 6 10 5 5 5 5
3 2 2 1 5 7 6 8 2 9

Sample Output

46 11

单调队列模板题,虽然赛后才补出来

#include <iostream>
using namespace std;
int a[10000005];
typedef struct node
{
    int data;
    int index;
}Node;
Node que[10000005];
int main()
{
    int t, head, tail;
    Node temp;
    scanf("%d", &t);
    while (t--)
    {
        long long qq = 0, ww = 0;
        int n, m, k, p, q, r, mod;
        scanf("%d%d%d%d%d%d%d", &n, &m, &k, &p, &q, &r, &mod);
        for (int i = 1; i <= k; i++)
            scanf("%d", &a[i]);
        for (int i = k + 1; i <= n; i++)
            a[i] = ((long long)p * a[i - 1] + (long long)q * i + r) % mod;

        head = 1, tail = 0;
        for (int i = n; i >= 1; i--)
        {
            while (head <= tail && que[tail].data <= a[i])
                tail--;
            temp.data = a[i];
            temp.index = i;
            que[++tail] = temp;
            while (head <= tail && que[head].index - i >= m)
                head++;
            if (i <= n - m + 1)
            {
                qq += i ^ que[head].data;
                ww += i ^ (tail - head + 1);
            }
        }
        printf("%lld %lld\n", qq, ww);
    }
}