迷宫问题

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45910 Accepted: 25166
Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

bfs最短路,做了这道题有点能理解为什么bfs出来的一定是最短路,因为到达终点的路不止一条,先到的肯定是最短路,然后之间return掉,注意回溯找路径的方法是用一个父节点数组存储每个节点的父亲节点,然后回溯一路往上面找就行了。
代码:

#include<iostream>
#include<queue>
#include<stack>
using namespace std;

const int maxn=1e3+10;
int maze[5][5],vis[5][5];
struct node{
	int x,y;
	node(int a,int b):x(a),y(b){}
	node(){}
};
int cnt;
struct node f[5][5];
struct node ans[maxn];
void bfs(int x,int y){
	queue<node>st;
	st.push(node(x,y));
	vis[x][y]=1;
	while(!st.empty()){
		int fxx=st.front().x;
		int fyy=st.front().y;
		st.pop(); 
		for(int i=1;i<=4;i++){
			int fx=fxx;int fy=fyy;
			if(i==1)fx-=1;
			if(i==2)fx+=1;
			if(i==3)fy-=1;
			if(i==4)fy+=1;
			if(fx<0||fx>5||fy<0||fy>5)continue;
			if(fx>=0&&fy>=0&&maze[fx][fy]==0&&!vis[fx][fy]){
				st.push(node(fx,fy));
				vis[fx][fy]=1;
				f[fx][fy].x=fxx;
				f[fx][fy].y=fyy;
			}
			if(fx==4&&fy==4){
				cnt=0;int t1,t2;
				ans[cnt].x=4;ans[cnt].y=4;
				while(f[fx][fy].x!=0||f[fx][fy].y!=0){
					t1=fx;t2=fy;//这里注意一下 
					cnt++;
					ans[cnt].x=f[fx][fy].x;
					ans[cnt].y=f[fx][fy].y;
					fx=f[t1][t2].x;//如果不用中间变量会导致下一行出问题 
					fy=f[t1][t2].y;
				}
				return;
			} 
		}
	}
}
int main(){
	for(int i=0;i<5;i++){
		for(int j=0;j<5;j++){
			scanf("%d",&maze[i][j]);
		}
	}
	bfs(0,0);
	cout<<"(0, 0)"<<endl;
	for(int i=cnt;i>=0;i--){
		cout<<"("<<ans[i].x<<", "<<ans[i].y<<")"<<endl;
	}
}