题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1940
Time Limit: 2 Seconds Memory Limit: 65536 KB

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

L is the number of levels making up the dungeon. 

R and C are the number of rows and columns making up the plan of each level. 

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s). 

where x is replaced by the shortest time it takes to escape. 

If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

Problem solving report:

Description: 三维迷宫,判断从S能不能到达E。
Problem solving: 直接广搜。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int l, r, c;
char mp[35][35][35];
bool vis[35][35][35];
int dir[6][3] = {{0, 0, 1}, {0, 0, -1}, {0, 1, 0}, {0, -1, 0}, {1, 0, 0}, {-1, 0, 0}};
struct edge {
    int x, y, z, t;
    edge(int x_, int y_, int z_, int t_) {
        x = x_, y = y_, z = z_, t = t_;
    }
}p(0, 0, 0, 0);
int BFS(edge e) {
    queue <edge> Q;
    Q.push(e);
    int tx, ty, tz;
    vis[e.x][e.y][e.z] = true;
    while (!Q.empty()) {
        p = Q.front();
        Q.pop();
        if (mp[p.x][p.y][p.z] == 'E')
            return p.t;
        for (int i = 0; i < 6; i++) {
            tx = p.x + dir[i][0];
            ty = p.y + dir[i][1];
            tz = p.z + dir[i][2];
            if (tx >= 0 && tx < l && ty >= 0 && ty < r && tz >= 0 && tz < c && mp[tx][ty][tz] != '#' && !vis[tx][ty][tz]) {
                vis[tx][ty][tz] = true;
                Q.push(edge(tx, ty, tz, p.t + 1));
            }
        }
    }
    return -1;
}
int main() {
    while (scanf("%d%d%d", &l, &r, &c), l + r + c) {
        memset(vis, false, sizeof(vis));
        for (int i = 0; i < l; i++) {
            for (int j = 0; j < r; j++) {
                for (int k = 0; k < c; k++) {
                    scanf(" %c", &mp[i][j][k]);
                    if (mp[i][j][k] == 'S')
                        p = edge(i, j, k, 0);
                }
            }
        }
        int ans = BFS(p);
        if (~ans)
            printf("Escaped in %d minute(s).\n", ans);
        else printf("Trapped!\n");
    }
    return 0;
}