Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10 
1 2 4 2 1 1 
2 5 
1 4 2 1 
0 0

Sample Output


4

题目大意:

输入n和m分别表示拥有的钱币种数和所能买的最大价值,数组a存钱币的价值,数组c存每种钱币个数,求用这些钱币所能买到的最大价值。输入0 0表示结束。

C++

#include <iostream>
#include <cstring>
#define INF 0x3f3f3f3f
using namespace std;
int f[111111],a[111],c[111];
int n,m;
void OneZeroPack(int m,int v,int w)//01
{
    for(int i=m;i>=v;i--)
        f[i]=max(f[i],f[i-v]+w);
}
void CompletePack(int m,int v,int w)//完全
{
    for(int i=v;i<=m;i++)
        f[i]=max(f[i],f[i-v]+w);
}
void MultiplePack(int m,int v,int w,int num)  //多重
{
    if(v*num>=m)
    {
        CompletePack(m,v,w);
        return ;
    }
    int k=1;
    for(k=1;k<=num;k<<=1)
    {
        OneZeroPack(m,k*v,k*w);
        num=num-k;
    }
    if(num)
        OneZeroPack(m,num*v,num*w);
}
int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)  break;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
            cin>>c[i];
        memset(f,-INF,sizeof(f));
        f[0]=0;
        for(int i=0;i<n;i++)
        {
            MultiplePack(m,a[i],a[i],c[i]);
        }
        int sum=0;
        for(int i=1;i<=m;i++)
                if(f[i]>0)
                    sum++;
        cout<<sum<<endl;
    }
    return 0;
}