Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

 

 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

 

 

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

 

 

Sample Input

 

banana band bee absolute acm ba b band abc

 

 

Sample Output

 

2 3 1 0

 

 

Author

Ignatius.L

 

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const int N=5e5+3;///本题开到1e6会爆
int T[N][26];///字典树,每个结点下有26个子节点
int num[N];///num[i]以第i个节点所代表的前缀为前缀的单词个数
int pos=1;///总结点数

void Insert(char word[])///将单词插入字典树
{
    int root=0;
    for(int i=0;word[i];i++)
    {
        int tmp=word[i]-'a';
        if(T[root][tmp]==0)
            T[root][tmp]=pos++;
        root=T[root][tmp];///根节点下移
        num[root]++;
    }
    ///平常字典树需要加个判断,判断是否构成一个单词
}

int Find(char word[])///查找
{
    int root=0;
    for(int i=0;word[i];i++)
    {
        int tmp=word[i]-'a';
        if(T[root][tmp]==0)///该位字母不匹配 没有这样的前缀 返回
            return 0;
        root=T[root][tmp];///继续查单词的下一位
    }
    return num[root];///返回以该单词为前缀的字符串数目
}

int main()
{
    memset(T,0,sizeof(T));
    memset(num,0,sizeof(num));
    char word[11];
    while(gets(word))
    {
        if(word[0]==NULL)
            break;
        Insert(word);
    }
    while(gets(word))
        cout<<Find(word)<<'\n';
    return 0;
}