Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). 
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input


BAPC 
BAPC 
AZA 
AZAZAZA 
VERDI 
AVERDXIVYERDIAN

Sample Output



0

题目大意:

给个数 T,表示有T组测试数据; 
每个测试用例给两个字符串,第一个字符串的长度L1(1 ≤ |L1| ≤ 10,000),第二个字符串长度L2(1 ≤ |L2| ≤ 1,000,000) 
求第一个字符串在第二个字符串中出现的次数

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=10010;
char arr1[N*100],arr2[N];
int nt[N];
int n,m,s;
void getnt()
{
    int i=0,j=-1;
    nt[0]=-1;
    while(i<m)
    {
        if(j==-1||arr2[i]==arr2[j])
        {
            i++,j++;
            nt[i]=j;
        }
        else
            j=nt[j];
    }
}
int kmp()
{
    getnt();
    int i=0,j=0;
    s=0;
    while(i<n)
    {
        if(j==-1||arr1[i]==arr2[j])
            i++, j++;
        else
            j=nt[j];
        if(j>=m)
        {
            s++;
            j=nt[j];
        }
    }
    return s;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
         scanf("%s",arr2);
         scanf("%s",arr1);
         n=strlen(arr1);
         m=strlen(arr2);
         if(n<m)
            cout<<"0"<<endl;
         else
         {
             cout<<kmp()<<endl;
         }
    }
    return 0;
}