Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board
...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

理解错题目意思了!!!

题目意思是    从2开始,可以向着自己上下左右是0的方向搜索,但是你向一个方向搜索,就要搜到为1或者是边界才停止,这个时候算搜了一步。然后搜索到3为终点,当搜索的步数大于10的时候,搜索结束,无法到达,输出-1。

//Asimple
#include <iostream>
#include <sstream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <set>
#include <map>
#include <string>
#include <queue>
#include <limits.h>
#include <time.h>
using namespace std;
const int maxn = 25;
int dx[] = {-1,1,0,0}, dy[]={0,0,-1,1};
int n, m, num, T, k, x, y, len, ans;
int endx, endy;
int Map[maxn][maxn];
//边界 
bool worng(int x, int y) {
    return x<0 || x>=n || y<0 || y>=m;
}

void DFS(int x, int y, int num) {
    if( num > 10 ) return ;
    bool f;
    int nx, ny;
    for(int i=0; i<4; i++) {
        //不是0的方向不用搜索 
        if( Map[x+dx[i]][y+dy[i]]==1 ) continue;
        f = false;
        nx = x;
        ny = y;
        //一直划到顶 
        while( true ) {
            nx = nx+dx[i];
            ny = ny+dy[i];
            if( worng(nx, ny) ) {
                f = true;
                break;
            }
            //是0就向着这个方向一直搜 
            if( Map[nx][ny] == 0 ) continue;
            //碰到1停止搜索 
            else if( Map[nx][ny] == 1 ) break;
            else if( Map[nx][ny] == 3 ) {//终点 
                ans = min(ans, num);
                return ;
            }
        }
        if( f ) continue;
        Map[nx][ny] = 0;
        DFS(nx-dx[i], ny-dy[i], num+1);
        //回溯 
        Map[nx][ny] = 1;
    }
}

void input() {
    while( cin >> m >> n && ( n + m ) ) {
        ans = 11;
        memset(Map, 0, sizeof(Map));
        for(int i=0; i<n; i++) {
            for(int j=0; j<m; j++) {
                cin >> Map[i][j];
                if( Map[i][j] == 2 ) {
                    x = i;
                    y = j;
                }
            }
        }
        DFS(x, y, 0);
        if( ans < 10 ) {
            cout << ans+1 << endl;
        } else {
            cout << "-1" << endl;
        }
    }
}

int main(){
    input();
    return 0;
}