The Power Cube is used as a stash of Exotic Power. There are nn cities numbered 1,2,…,n1,2,…,n where allowed to trade it. The trading price of the Power Cube in the ii-th city is aiai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the ii-th city and choose exactly one of the following three options on the ii-th day: 

1. spend aiai dollars to buy a Power Cube 
2. resell a Power Cube and get aiai dollars if he has at least one Power Cube 
3. do nothing 

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the nn cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning. 

Input

There are multiple test cases. The first line of input contains a positive integer TT (T≤250T≤250), indicating the number of test cases. For each test case: 
The first line has an integer nn. (1≤n≤1051≤n≤105) 
The second line has nn integers a1,a2,…,ana1,a2,…,an where aiai means the trading price (buy or sell) of the Power Cube in the ii-th city. (1≤ai≤1091≤ai≤109) 
It is guaranteed that the sum of all nn is no more than 5×1055×105. 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0 0


        
  

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. profit = 0

题意:有 n 天,给出每天物品的价格,一个人最初有无限多的钱,每天可以选择买一个物品、卖一个物品或者什么都不做,问这个人的最大收益。

思路:用优先队列维护之前每一天的价格(从小到大),如果队顶的价格 < 当前价格,说明可以在队顶这一天买,当前卖出。然后将一天的价格入队两次,因为当前的收益可能不是最优的,比如1 2 10,将2 push两次,可以计算出2 - 1 = 1和10 - 2 = 8,从而得到最大利润10 - 2 + 2 - 1 = 9。即把第二天的价格当作跳板,卖出再买入,相当于没买。

思路来自https://blog.csdn.net/bpdwn2017/article/details/82119414

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const double eps = 1e-5;
const int N = 1e5 + 10;
int n;
struct node {
    int a, tp;
    bool operator < (const node &x) const {
        if(a != x.a) return a > x.a;
        else return tp > x.tp;
    }
};

int main() {
    int t, val;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        ll ans = 0;
        int cnt = 0;
        priority_queue<node>q;
        node tmp;
        while(!q.empty()) q.pop();
        for(int i = 1; i <= n; ++i) {
            scanf("%d", &val);
            tmp.a = val;
            tmp.tp = 2;
            if(!q.empty() && q.top().a < val) {
                ans += (ll)(val - q.top().a);
                cnt += q.top().tp;
                q.pop();
                q.push(tmp);
                tmp.tp = 0;
                q.push(tmp);
            }
            else q.push(tmp);
        }
        printf("%lld %d\n", ans, cnt);
    }
    return 0;
}