题目链接:http://nyoj.top/problem/546

  • 内存限制:64MB 时间限制:1000ms

题目描述

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

输入描述

Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000. 
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line. 

输出描述

For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case. 

样例输入

1 0 1 2 0 0 0 0 2 0
1 0 0 0 1 1 0 0 0 0
0 0 0 0 0 0 0 0 0 0

样例输出

#1:Can't be divided.

#2:Can be divided.

解题思路

直接DFS搜索,这道题其实就是让你求能不能凑成总价值的一半。首先记录每一件宝物的数量,然后从最大的宝物开始拿,直到找到总价值的一半。

#include <bits/stdc++.h>
using namespace std;
int n[15], temp, sum;
void DFS(int s) {
    if (s == sum) {
        temp = 1;
        return ;
    }
    for (int i = 10; i >= 1; i--) {
        if (n[i] && s + i <= sum) {
            n[i]--;
            DFS(s + i);
            if (temp)
                return ;
        }
    }
}
int main() {
    int t, i, j, test;
    for (test = 1; ; test++) {
        sum = temp = 0;
        for (i = 1; i <= 10; i++) {
            scanf("%d", &n[i]);
            sum += n[i] * i;
        }
        if (!sum)
            break;
        if (sum & 1) {
            printf("#%d:Can't be divided.\n\n", test);
            continue;
        }
        sum >>= 1;
        DFS(0);
        if (temp)
            printf("#%d:Can be divided.\n\n", test);
        else printf("#%d:Can't be divided.\n\n", test);
    }
    return 0;
}