Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 24208 Accepted: 11127

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output

3
4

题目大意:给你一个s*s的矩阵要你完成4个操作,0:初始化,1 X Y A: 将矩阵[x][y]修改成A,2 L B R T:将矩阵[L][B]-[R][T]的和输出来,4退出。
思路:
这题对时间复杂度要求比较严格,O(n^2)的暴力,直接T掉,这题需要采用二维树状数组去维护。代码比较简单,理解确是比较难的我的理解是每行每列都是一个一维的树状数组。求和公式getsum(x2,y2)+getsum(x1-1,y1-1)-getsum(x2,y1-1)-getsum(x1-1,y2);这个在本子上稍微画画应该还是能明白的。还剩两个题,刷完就准备复习期末考试了,加油!
代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int maxn=1e3+10;
int sum[maxn*2][maxn*2];
int s;
void init(){
	scanf("%d",&s);
	memset(sum,0,sizeof(sum));
}

void add(int x,int y,int v){
	for(;x<=s+1;x+=(x&-x)){
		for(int j=y;j<=s+1;j+=(j&-j)){
			sum[x][j]+=v;
		}
	}
}
int getsum(int x,int y){
	int s=0;
	for(;x;x-=(x&-x)){
		for(int j=y;j;j-=(j&-j)){
			s+=sum[x][j];
		}
	}
	return s;
}
int query(int x1,int y1,int x2,int y2){
	return getsum(x2,y2)+getsum(x1-1,y1-1)-getsum(x2,y1-1)-getsum(x1-1,y2);
}
int main(){
	int ins;
	while(scanf("%d",&ins)&&ins!=3){
		int x,y,a,b,v;
		switch(ins){
			case 0:init();break;
			case 1:scanf("%d%d%d",&x,&y,&v);add(x+1,y+1,v);break;
			case 2:scanf("%d%d%d%d",&x,&y,&a,&b);printf("%d\n",query(x+1,y+1,a+1,b+1));break;
		}
	}
}