Roadblocks

Time Limit: 2000MS Memory Limit: 65536K

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)。

思路:

一个次短路的问题,也就是在求最短路的时候,不断更新次短路,还是用堆优化的方式用Dijkstra不断更新最短路,在更新最短路如果比最短路小就交换最短路,在这基础上比次短路小就更新次短路。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <map>
#include <queue>
#include <cstring>
using namespace std;
const int maxn = 5010;
const int inf = 0x3f3f3f3f;
typedef pair<int, int> P;
vector<P > v[maxn];
int d[maxn], d2[maxn];
int n, m;
void Dijkstra() {
    memset(d, inf, sizeof(d));
    memset(d2, inf, sizeof(d2));
    d[1] = 0;
    priority_queue<P, vector<P >, greater<P> > q;
    q.push(make_pair(0, 1));
    while (!q.empty()) {
        int now = q.top().second, dn = q.top().first;
        q.pop();
        if (d2[now] < dn) continue;
        for (int i = 0; i < v[now].size(); i++) {
            int x = v[now][i].first;
            int dis = dn + v[now][i].second;
            if (d[x] > dis) {
                swap(d[x], dis);
                q.push(make_pair(d[x], x));
            }
            if (d2[x] > dis && d[x] < dis) {
                d2[x] = dis;
                q.push(make_pair(d2[x], x));
            }
        }
    }
    printf("%d\n", d2[n]);
}
int main() {
    scanf("%d %d", &n, &m);
    for (int i = 0; i < m; i++) {
        int a, b, c;
        scanf("%d %d %d", &a, &b, &c);
        v[a].push_back(make_pair(b, c));
        v[b].push_back(make_pair(a, c));
    }
    Dijkstra();
    return 0;
}