题目链接
A - Number Sequence
Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1

#include<bits/stdc++.h>
using namespace std;
const int MM=1e6+5;
int st,tn;
int F[MM];
int t,s[MM],p[MM];
int KMP(int s[MM],int p[MM],int st,int tn,int F[MM])
{
    int i=0,j=0;
    while(i<st&&j<tn)
    {
        if(j==-1||s[i]==p[j])
        {
            i++;
            j++;
        }
        else
        {
            j=F[j];
        }
    }
    if(j==tn)
        return i-j;//返回匹配成功最开始的位置
    else
        return -1;//匹配不成功
}
void Get(int p[MM],int tn,int F[MM])
{
    F[0]=-1;
    int j=0,k=-1;
    while(j<tn)
    {
        if(k==-1||p[j]==s[k])
        {
            F[++j]=++k;
        }
        else
            k=F[k];
    }
}
int main()
{
   scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&st,&tn);
        for(int i=0; i<st; i++)
        {
            scanf("%d",&s[i]);
        }
        for(int i=0; i<tn; i++)
            scanf("%d",&p[i]);
        Get(p,tn,F);
        int w=KMP(s,p,st,tn,F);
        if(w==-1)
            printf("-1\n");
        else
            printf("%d\n",w+1);
    }
    return 0;
}

B - Oulipo
题目链接
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

#include<bits/stdc++.h>
using namespace std;
const int MM=1e6+5;
int st,tn;
int F[MM];
int t;
int sum;
vector<int>mathp;//
void Get(const char s[],int ls,int F[])
{
    F[0]=-1;
    int j=0,k=-1;
    while(j<ls)
    {
        if(k==-1||s[j]==s[k])
        {
            F[++j]=++k;
        }
        else
            k=F[k];
    }
}
int KMP(const char s[],const char p[])//p主 s是次
{
    int ls,lt,i=0,j=0;
    ls=strlen(p);
    lt=strlen(s);
    Get(s,lt,F);
    mathp.clear();//tot=0;
    while(i<ls&&(ls-i)>=(lt-j))
    {
        while(j!=-1&&p[i]!=s[j])
            j=F[j];
        i++;
        j++;
        if(j>=lt)
        {
            mathp.push_back(i-j+1);//++tot;
            j=F[j];
        }
    }
    return mathp.size();//返回的是次字符串在主字符串的次数;
}
int main()
{
    scanf("%d",&t);
    char s[MM];
    char p[MM];
    while(t--)
    {
        scanf("%s",s);
        getchar();
        scanf("%s",p);
        getchar();
        sum=0;
        printf("%d\n",KMP(s,p));
    }
    return 0;
}