Description:

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input:

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output:

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input:

2
3
3 5 1
1
1

Sample Output:

John
Brother

题目链接

今天省赛有一道H题博弈论不会写,赛后问大佬才知道是尼姆博弈,赶快来学习一下。
题目本身是一个裸尼姆博弈,尼姆博弈详解
若全为1则直接用奇偶性判断,否则就全部异或判断是否为0.
这道题目的胜负反过来了。

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const int maxn = 1e5+5;
const int mod = 1e9+7;
const double eps = 1e-8;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;
void fre() {
    freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
}

int t;
int n;
int a[maxn];
int temp;
int cnt;

int main(){
    //fre();
    scanf("%d", &t);
    while (t--) {
        temp = 0;
        cnt = 0;
        scanf("%d", &n);
        for (int i = 0; i < n; ++i) {
            scanf("%d", &a[i]);
            temp ^= a[i];
            if (a[i] > 1) {
                cnt++;
            }
        }
        if ((temp == 0 && cnt > 1) || (n % 2 && cnt == 0)) {
            printf("Brother\n");
        }
        else {
            printf("John\n");
        }
    }
    return 0;
}