Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23283    Accepted Submission(s): 7554
Special Judge

 

Problem Description

The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:
1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

 

Input

The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

 

Output

For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

 

Sample Input

5 6

.XX.1.

..X.2.

2...X.

...XX.

XXXXX.

5 6

.XX.1.

..X.2.

2...X.

...XX.

XXXXX1

5 6

.XX...

..XX1.

2...X.

...XX.

XXXXX.

 

Sample Output

It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

题意:

    从(0,0)到(n,m)的最短时间,如果是数字n就代表有n滴血的怪物需要花费一个单位时间。

思路:

    广搜,使用dis数组记录前一个位置到达此刻位置所走的方向。

代码:

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
char map[1010][1010];
int book[1010][1010];
int dis[1010][1010];      //存储路径 
int n,m;
struct node
{
	int x;
	int y;
	int step;
	friend bool operator < (node n1,node n2)   //自定义优先级。在优先队列中,优先级高的元素先出队列。
	{
		return n1.step>n2.step;     //step小的优先级高 
	}
};
int judge(int x,int y)
{
	if(x<1||x>n||y<1||y>m)
		return 1;
	if(book[x][y]==1)
		return 1;
	if(map[x][y]=='X')
		return 1;
	return 0;
}
int bfs(int x,int y)
{
	priority_queue <node> q;    //定义一个优先队列 
	node pre,next;
	int next_[4][2]={0,1, 1,0, 0,-1, -1,0 };
	int k,tx,ty,s;
	pre.x=x;
	pre.y=y;
	pre.step=0;
	q.push(pre);               //第一个元素入队 
	while(!q.empty())
	{
		pre=q.top();           //队首出队 
		q.pop();
		if(pre.x==n && pre.y==m)
			return pre.step;
		for(k=0;k<4;k++)
		{
			tx=pre.x+next_[k][0];
			ty=pre.y+next_[k][1];
			if(judge(tx,ty)==1)
				continue;
			next.x=tx;
			next.y=ty;
			book[tx][ty]=1;
			dis[tx][ty]=k;
			if(map[tx][ty]>='1'&&map[tx][ty]<='9')
			{
				s=map[tx][ty]-'0';
				next.step=pre.step+s+1;
			}
			else
			{
				next.step=pre.step+1;
			}
			q.push(next);       //入队 
		}
	}
	return 0;
}
int main()
{
	int i,j,step,s,tx,ty;
	node way[10010];
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
		{
			getchar();
			for(j=1;j<=m;j++)
			scanf("%c",&map[i][j]);
		}
		book[1][1]=1;
		step=bfs(1,1);
		if(step)
		{
			//还原路径 
			tx=n;ty=m;
			for(i=step;i>=0;i--)
			{
				way[i].x=tx;
				way[i].y=ty;
				if(map[tx][ty]>='1'&&map[tx][ty]<='9')
				{
					s=map[tx][ty]-'0';
					for(j=1;j<=s;j++)
					{
						way[i-j].x=tx;
						way[i-j].y=ty;
					}
					i-=s;
				}
				if(dis[tx][ty]==0)	ty--;
				else if(dis[tx][ty]==1)	tx--;
				else if(dis[tx][ty]==2)	ty++;
				else if(dis[tx][ty]==3)	tx++;
			}
			printf("It takes %d seconds to reach the target position, let me show you the way.\n",step);
			for(i=1;i<=step;i++)
			{
				printf("%ds:(%d,%d)->(%d,%d)\n",i,way[i-1].x-1,way[i-1].y-1,way[i].x-1,way[i].y-1);
				if(map[way[i].x][way[i].y]>='1'&&map[way[i].x][way[i].y]<='9')
				{
					s=map[way[i].x][way[i].y]-'0';
					for(j=1;j<=s;j++)
						printf("%ds:FIGHT AT (%d,%d)\n",i+j,way[i+j].x-1,way[i+j].y-1);
					i+=s;
				}
			}
		}
		else
			printf("God please help our poor hero.\n");
		printf("FINISH\n");
	}
	return 0;
}