Parity game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15448 Accepted: 5858

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even' orodd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even' means an even number of ones andodd’ means an odd number).
Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output

3

题目大意:
有一个长度为[1,n]的区间,先给出每个区间“1”的个数(even表示偶数,odd奇数),让你前面多少句话是正确的。
思路:
额看了大佬的题解做出来的,看了半天才看懂,路径压缩公式那个很简单关键是两棵树合并我不会,然后大佬是用向量做的,但是向量做法是没有严格的证明的,只能试着去做一下,还有这里的n的范围很大有10亿,一维数组显然是存不下的,所以这里用了离散化的做法,因为只要5000条边用map存储边就好了,我主要想讲一下两个重要的公式:

r[fx]=abs(d+r[y]-r[x])%2;

当两棵树合并的时候,用的就是这个公式,但是我之前一直没看懂,不过今天好像看懂了,可惜没有证明

这个公式讲完还有一个公式

abs(r[x]-r[y])!=d

当我们根据前面的条件推出某个答案时,和题目给的不一样可以用这个公式取验证。

代码:

#include<iostream>
#include<map>
#include<cmath>
using namespace std;
        
int n,m;
map<int,int> f;
map<int,int> r; 
int find(int x){
	if(!f[x])
	return x;
	int t=f[x];
	f[x]=find(f[x]);
	r[x]^=r[t];//路径压缩关系公式推导 
	return f[x];
}
int main(){
	char str[10];
	int x,y,ans,flag,d,fx,fy;
	while(scanf("%d",&n)!=EOF){
		flag=1;
		r.clear();
		f.clear();
		scanf("%d",&m);
		for(int i=1;i<=m;i++){
			scanf("%d%d",&x,&y);
			cin>>str; 
			x--;//让每个区间-1,就变得连续起来了真神奇 
			if(str[0]=='e'){
				d=0;
			}else{
				d=1;
			}
			fx=find(x);
			fy=find(y);
			if(fx!=fy){
				f[fx]=fy;
				r[fx]=abs(d+r[y]-r[x]);
			}else if(flag==1&&abs(r[x]-r[y])!=d){
				flag=0;
				ans=i;
			} 
		}
		if(flag){
			cout<<m<<endl;
		}else{
			cout<<ans-1<<endl;
		}
	}
}