Cow Contest

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20507   Accepted: 11365

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

USACO 2008 January Silver

题意:

有 n 头牛决斗,现知 m 个排名次序,a  b 说明牛 a 打败了牛 b,问现有多少头牛的名次确定了

思路:

当一头牛和其他的牛都有胜败关系时,这头牛的名次是确定的。

 

floyd + 传递闭包(模板)

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
typedef long long ll;
const int N = 120;

int mp[N][N];
int n, m;

void floyd()
{
    for(int k = 1; k <= n; ++k)
    {
        for(int i = 1; i <= n; ++i)
        {
            for(int j = 1; j <= n; ++j)
            {
                mp[i][j] = mp[i][j] || (mp[i][k] && mp[k][j]);
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        memset(mp, 0, sizeof(mp));
        int a, b;
        while(m--)
        {
            scanf("%d%d", &a, &b);
            mp[a][b] = 1;
        }
        floyd();
        int ans = 0, cnt;
        for(int i = 1; i <= n; ++i)
        {
            cnt = 0;
            for(int j = 1; j <= n; ++j)
            {
                if(mp[i][j] || mp[j][i])    //i在j前或i在j后
                    cnt++;
            }
            if(cnt == n - 1)
                ans++;
        }
        cout<<ans<<'\n';
    }
    return 0;
}

floyd + 传递闭包 + bitste优化

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <bitset>
using namespace std;
typedef long long ll;
const int N = 120;

bitset<N> mp[N];
int n, m;

void floyd()
{
    for(int k = 1; k <= n; ++k)
    {
        for(int i = 1; i <= n; ++i)
        {
            if(mp[i][k])
            {
                mp[i] |= mp[k];
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        int a, b;
        while(m--)
        {
            scanf("%d%d", &a, &b);
            mp[a][b] = 1;
        }
        floyd();
        int ans = 0, cnt;
        for(int i = 1; i <= n; ++i)
        {
            cnt = 0;
            for(int j = 1; j <= n; ++j)
            {
                if(mp[i][j] || mp[j][i])    //i在j前或i在j后
                    cnt++;
            }
            if(cnt == n - 1)
                ans++;
        }
        cout<<ans<<'\n';
    }
    return 0;
}