Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0

-1 -1

Sample Output

Yes
Yes
No

///@zhangxiaoyu
///2015/7/27

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<vector>
#include<stack>
#include<map>
#include<queue>
#include<iostream>
using namespace std;

int fa[100010];

int find(int x)///查找某元素属于哪个集合
{
    if(x==fa[x])///如果一个节点的父亲节点等于它自己,则此节点为根节点
        return x;
    else
       return fa[x]=find(fa[x]);///路径压缩,降低时间复杂度
}

void contact(int x,int y)///合并两个集合
{
    x=find(x);
    y=find(y);
    if(x>y)
        fa[x]=y;
    else if(y>x)
        fa[y]=x;
}

int main()
{
    int x,y;
    int circle;
    int vis[100010];
    while(~scanf("%d%d",&x,&y))
    {
        if(x==-1&&y==-1)
            break;
        else if(x==0&&y==0)
        {
            printf("Yes\n");
        }
        else
        {
            memset(vis,false,sizeof(vis));///标记是否已经加入集合fa
            for(int i=1;i<=100010;i++)
                fa[i]=i;
            contact(x,y);
            vis[x]=1,vis[y]=1;
            int pos;
            circle=1,pos=1;
            while(~scanf("%d%d",&x,&y))
            {
                if(x==0&&y==0)
                    break;
                if(vis[x]==0)
                {
                    pos++;
                    vis[x]=true;
                }
                if(vis[y]==0)
                {
                    pos++;
                    vis[y]=true;
                }
///这里仔细想一下就知道了,姿势较丑
                if(find(x)==find(y))
                    circle=0;
                else
                    pos--;///无环节点数不断减一,判断最后是否剩下一个点即可

                contact(x,y);
            }
            if(circle&&pos==1)
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}