学习博客:
学习博客1
ppt
带示例的博客2
博客3

入门题:HDU1695
题解1
优化根号n版

GCD

Given 5 integers: a, b, c, d, k, you’re to find x in a…b, y in c…d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you’re only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
Output
For each test case, print the number of choices. Use the format in the example.
Sample Input
2
1 3 1 5 1
1 11014 1 14409 9
Sample Output
Case 1: 9
Case 2: 736427

Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+7;
bool vis[maxn];
int prime[maxn],mu[maxn];
int cnt;

void Init(){
    int N=maxn;
    memset(prime,0,sizeof(prime));
    memset(mu,0,sizeof(mu));
    memset(vis,0,sizeof(vis));
    mu[1] = 1;
    cnt = 0;
    for(int i=2; i<N; i++){
        if(!vis[i]){
            prime[cnt++] = i;
            mu[i] = -1;
        }
        for(int j=0; j<cnt&&i*prime[j]<N; j++){
            vis[i*prime[j]] = 1;
            if(i%prime[j]) mu[i*prime[j]] = -mu[i];
            else{
                mu[i*prime[j]] = 0;
                break;
            }
        }
    }
}

void getMu(){
    int N=maxn;
    for(int i=1;i<N;++i){
        int target=i==1?1:0;
        int delta=target-mu[i];
        mu[i]=delta;
        for(int j=2*i;j<N;j+=i)
            mu[j]+=delta;
    }
}

int main()
{
    ios::sync_with_stdio(false);
    int a,b,c,d,k;
    int t,Case=0;
    Init();
    cin>>t;
    while(t--){
        cin>>a>>b>>c>>d>>k;
        cout<<"Case "<<++Case<<": ";
        if(k==0){
            cout<<"0"<<endl;
            continue;
        }
        b/=k,d/=k;
        long long ans1=0,ans2=0;
        long long h = min(d,b);
        for(int i=1;i<=h;i++){
            ans1+=(long long)mu[i]*(b/i)*(d/i);
        }
        for(int i=1;i<=h;i++){
            ans2+=(long long)mu[i]*(h/i)*(h/i);
        }
        cout<<ans1-ans2/2<<endl;
    }
    return 0;
}