A + B Problem II
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

PE了四次,搜了题解才知道出最后一个样例外输出两个换行,最后一个换行

#include <bits/stdc++.h>
using namespace std;
int add(int a[],int b[])
{
    int k;
    k=a[0]>=b[0]?a[0]:b[0];
    for(int i=1;i<=k;i++)
    {
        a[i+1]+=(a[i]+b[i])/10;
        a[i]=(a[i]+b[i])%10;
    }
    if(a[k+1])
        a[0]=k+1;
    else
        a[0]=k;
    return 0;
}
int main()
{
    int t,n,m,i,j,a[1050],b[1050];
    string s1,s2;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        cin>>s1>>s2;
        a[0]=s1.size();
        b[0]=s2.size();
        for(j=1;j<=a[0];j++)
            a[j]=s1[a[0]-j]-48;
        for(j=1;j<=b[0];j++)
            b[j]=s2[b[0]-j]-48;
        add(a,b);
        cout<<"Case "<<i<<":"<<'\n';
        cout<<s1<<" + "<<s2<<" = ";
        for(j=a[0];j>0;j--)
            cout<<a[j];
        cout<<'\n';
        if(i<t)
            cout<<'\n';
    }
    return 0;
}