Buy Tickets

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.



       如果按顺序一个一个人的插入的话,那么这个人当前的位置不一定是最终的位置……

      但是如果是从最后一个开始往前插空,最后一个***去的位置一定是固定的,所以应该从最后一个开始往前固定每个人的座位,用线段树维护每个区间的空位数,***去后区间空位数减一即可。



#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a[200100], p[200100], v[200100];
int tree[200100* 4 + 17];
int n, maxn;
void build(int p, int l, int r)
{
	if (l == r){tree[p]= 1; return;}
	int mid = (l + r) / 2;
    build(p * 2, l, mid);
    build(p * 2 + 1, mid + 1, r);
    tree[p] = tree[p * 2] + tree[p * 2 + 1];
}
int find(int p, int l, int r, int x)
{
	tree[p]--;
	int mid = (l + r) / 2;
	if (l == r) return l;
	if (x <= tree[p * 2]) return find(p * 2, l, mid, x);
	if (x > tree[p * 2]) return find(p * 2 + 1, mid + 1, r, x - tree[p * 2] );
}
int main()
{
    while (scanf("%d", &n)!=EOF)
    {
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &p[i], &v[i]);
		}
		build(1, 1, n);
		for (int i = n; i >= 1; i--)
		{
			a[find(1, 1, n, p[i] + 1)] = v[i];
		}
		for (int i = 1; i <= n; i++)
		{
			printf("%d ", a[i]);
		}
		printf("\n");
    }
	return 0;
}