Cheapest Palindrome
Time Limit: 2000MS Memory Limit: 65536K
Description
Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).
Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).
FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.
Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.
Input
Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800
Sample Output
900
Hint
If we insert an “a” on the end to get “abcba”, the cost would be 1000. If we delete the “a” on the beginning to get “bcb”, the cost would be 1100. If we insert “bcb” at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
思路:
因为本题要求计算的回文字串的添加和删除的话的添加和删除,第一次看可能觉得有两种情况,但是实际上只需要记录那个最小的就行了,因为比如ab的话,假如删除a比添加a少的话,那么肯定选择删除a反之也一样,而后面的循环实质上就行记录每个的回文子串,比如刚开始是一个字母的回文子串,然后在1的基础上记录数量为2的回文子串(我在代码中有个注释的地方,可以把注释删除,来看看其中的奥秘,如果没有看如何计算回文子串字母的最大的数量的话,我建议可以先查查那个,这样可以更好地理解的这段代码)。
#include <iostream>
using namespace std;
int dp[2020][2020] = {0};
int main() {
int n, m;
int book[256] = {0};
string s;
cin >> n >> m >> s;
for (int i = 0; i < n; i++) {
char c;
int add, erase;
cin >> c >> add >> erase;
book[c] = min(add, erase);
}
for (int k = 0; k < m; k++) {
int j = k;
for (int i = 0; i < m && j < m; i++) {
dp[i][j] = 0x7fffffff;
if (s[i] == s[j]) dp[i][j] = dp[i + 1][j - 1];
else {
dp[i][j] = min(dp[i][j - 1] + book[s[j]], dp[i + 1][j] + book[s[i]]);
}
//cout << i << " " << j << " " << dp[i][j] << endl;
j++;
}
}
cout << dp[0][m - 1];
return 0;
}