Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51527 Accepted: 21543 Special Judge
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题目大意:输出十进制数能够整除n的数(仅由1,0组成),开始以为是输出整除n任意一个二进制数。。。
比较简单的搜索,bfs,把求解的答案想象成一颗由0,1组成的完全二叉树,然后bfs一遍就行了。
有一个坑的地方,while(!st.empty())这个过不了,while(1)才能过。。。。也是看的评论才知道的。。。。不然一辈子过不了了
g++能过,c++过不了。。
代码:
#include<iostream>
#include<queue>
#include<cstdio>
using namespace std;
typedef long long ll;
ll bfs(int n,ll s){
queue<ll>st;
st.push(s);
while(1){
ll now=st.front();st.pop();
if(now%n==0){
return now;
}
st.push((ll)now*10);
st.push((ll)now*10+1);
}
}
int main(){
int n;
while(scanf("%d",&n)==1&&n){
cout<<bfs(n,1)<<endl;
}
}